FileWave Alliance

The Official Community Forum
  • Page:
  • 1

TOPIC: iOS - filesets for older versions of apps?

iOS - filesets for older versions of apps? 28 Sep 2017 22:03 #2752

  • Jocelyn Oyama
  • Jocelyn Oyama's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 6
  • Thank you received: 0
Is there a way to package an iOS fileset for an older version of an app? As of yesterday, Google Drive updated to a new version that no longer supports ipad 4's so I am unable to install it via FW for our fleet of ipads. I can install it manually using an AppleID and the App Store asks me if I want to use an older version instead. This requires a lot more work though so I'm hoping for a FW solution.

iOS - filesets for older versions of apps? 28 Sep 2017 22:17 #2753

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
If you have built a VPP app fileset, then the latest version of the app that is compatible will get deployed to the endpoint.

iOS - filesets for older versions of apps? 28 Sep 2017 22:51 #2754

  • Jocelyn Oyama
  • Jocelyn Oyama's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 6
  • Thank you received: 0
This unfortunately doesn't seem to be the case as when I try to deploy it, the app installs then says there was an error and try again, constantly going in the same loop. It never successfully installs. The ipad is on iOS 10.3.3.

iOS - filesets for older versions of apps? 28 Sep 2017 23:10 #2755

  • Jocelyn Oyama
  • Jocelyn Oyama's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 6
  • Thank you received: 0
Here is a picture of the error message. Hitting Retry makes the ipad download and install it again but it just goes back to the error in a neverending loop. Hitting Done makes the msg and app disappear until the ipad checks in again and tries again later.
Attachments:
Last Edit: by Jocelyn Oyama. Reason: added attachment

iOS - filesets for older versions of apps? 28 Sep 2017 23:12 #2756

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
Thanks for the extra info. I can indeed reproduce this behaviour and will bring this up with our engineering team to see if there is a known solution.

iOS - filesets for older versions of apps? 28 Sep 2017 23:17 #2757

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
I just tried installing the app "Google Drive" on a 9.3.5 device via the App Store directly rather than via Filewave and I get the same behaviour... "this app is not compatible with your device".

iOS - filesets for older versions of apps? 29 Sep 2017 00:07 #2758

  • Jocelyn Oyama
  • Jocelyn Oyama's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 6
  • Thank you received: 0
This is the message I get when I manually install from App Store even though the ipad is already on 10.3.3. It installs successfully and am able to open after that though.
Attachments:

iOS - filesets for older versions of apps? 29 Sep 2017 14:18 #2759

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
Ah. I will test further on a 10.3.3 ipad.

iOS - filesets for older versions of apps? 29 Sep 2017 16:43 #2760

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
Well, I couldn't find a 10.3.3 iPad 4, but I did test on a 10.1.1 iPad Air 1 (iPad4,2) and Google Drive actually installed fine, even at the same version as that installed on my iPad Mini 2 Retina @ iOS 11.



But, on the iPad Air, if I attempt to install manually via the App Store, I don't get the same message as you stating that the older version will be used. Seems to me that the restriction is more based on hardware than the current running iOS version. I'll see if I can find someone with an iPad 4 to test further. If I can't find such a configuration, maybe the best thing would be to open a support case to continue troubleshooting.
Attachments:

iOS - filesets for older versions of apps? 04 Oct 2017 17:17 #2764

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
For anyone else that has run into this issue, I just want to provide an update.

It appears that support for certain devices on some apps (Google Drive included) has been removed. To know for sure if your device is supported, you can reference the "Compatibility" section in the iTunes page for the app in question.

The main problem here is that when the iOS device checks in with FileWave, and receives an InstallApplication command (because the versions of the App are different), the app will indeed attempt to install, but the old version of the app will be removed first. This leaves a situation where the app is no longer present on the device.

Apple is aware of the issue and it is recommended that you contact Apple Enterprise support with the following information:
-- device console logs from a sample device affected. You can get the iOS Console log viewer , which will allow you to export the console log.
-- number of devices and users affected

FileWave also has an open ticket with Apple that you can reference, 100313401590.

regards,
dave
The following user(s) said Thank You: Jocelyn Oyama

iOS - filesets for older versions of apps? 12 Oct 2017 19:50 #2776

  • Jocelyn Oyama
  • Jocelyn Oyama's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 6
  • Thank you received: 0
Hi Dave, just wanted to let you know that I imaged some older ipads today and it appears that Google Drive is now installing successfully. Thank you for your help.

iOS - filesets for older versions of apps? 12 Oct 2017 22:41 #2777

  • Dave Herder
  • Dave Herder's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 39
  • Karma: 2
  • Thank you received: 2
Thanks for the update!
  • Page:
  • 1