FileWave Alliance

The Official Community Forum
  • Page:
  • 1

TOPIC: Can't create server log file

Can't create server log file 03 Sep 2010 14:53 #209

  • jean-philippe.sakael
  • jean-philippe.sakael's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 43
  • Karma: 1
  • Thank you received: 4
ISSUE : Error message "Failed to create the server log file : fwxserver-log.txt" if I go to the "Server" menu -> "Get Logfile" in FileWave Admin


CONFIGURATION :


My FW server setup : FW 3.7.6 uptated to FW 4.1, running on a Mac OS X Server 10.6.4 Mac Pro


My FW admin setup : Mac Pro running Mac OS X 10.5.8


REGRESSION :


This will not occur if I do the same directly on the Mac Pro running FW server, but since this computer is located on a secondary site this is not a suitable option


I don't get specific log messages on the FW admin Mac Pro


Here is what I got on the FW server side :


What I get when asking for server log from the server itself and quits

03/09/10 16:41:56 com.filewave.fwldap[5104] 3000148 [0xa0420500] DEBUG ldap.controller null - fetching server records - begin
03/09/10 16:41:56 com.filewave.fwldap[5104] 3000149 [0xa0420500] DEBUG ldap.controller null - fetching server records - done
03/09/10 16:42:16 com.filewave.fwxserver-admin[5100] 3020487 [0xb0513000] INFO root null - Admin user 'FileWave XAdmin' is being logged off.
03/09/10 16:42:16 com.filewave.fwxserver-admin[5100] 3020487 [0xb0513000] INFO root null - number of connected admins is 0, resetting change data manager
03/09/10 16:42:16 [0x0-0x53053].FileWave Admin[5888] 65527 [0xa0420500] INFO root null - The Admin Quit in response to signal aboutToQuit
03/09/10 16:42:16 com.filewave.fwxserver-admin[5100] 3020724 [0xa0420500] INFO root ADM| - permanent connection from ip XXX.XXX.XXX.XXX:50092 has closed for socket 21
03/09/10 16:42:16 [0x0-0x53053].FileWave Admin[5888] QThread: Destroyed while thread is still running
03/09/10 16:42:16 com.filewave.fwxserver-admin[5100] 3020781 [0xa0420500] INFO root ADM| - permanent connection from ip XXX.XXX.XXX.XXX:50091 has closed for socket 15

I then log in from my Admin machine and tries the same

03/09/10 16:42:31 com.filewave.fwxserver-admin[5100] 3035429 [0xb0513000] INFO root null - Admin FileWave XAdmin logged on.
03/09/10 16:42:31 com.filewave.fwxserver-admin[5100] 3035440 [0xb0513000] INFO root null - permanent connection from ip/port XXX.XXX.XXX.XXX:58082 constructed (socket 15)
03/09/10 16:42:33 com.filewave.fwxserver-admin[5100] 3036848 [0xb0513000] INFO root null - permanent connection from ip/port XXX.XXX.XXX.XXX:58083 constructed (socket 21)
03/09/10 16:42:56 com.filewave.fwldap[5104] 3060148 [0xa0420500] DEBUG ldap.controller null - fetching server records - begin
03/09/10 16:42:56 com.filewave.fwldap[5104] 3060149 [0xa0420500] DEBUG ldap.controller null - fetching server records - done

This features works on 06 Sep 2010 09:04 #805

  • jean-philippe.sakael
  • jean-philippe.sakael's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 43
  • Karma: 1
  • Thank you received: 4
This features works on another computer where FileWave Admin has been installed.

Hi,you need to remove the 06 Sep 2010 11:27 #806

  • P-M Lejon
  • P-M Lejon's Avatar
  • Offline
  • 5th level - Black Belt
  • 5th level - Black Belt
  • Posts: 92
  • Karma: 3
  • Thank you received: 15
Hi,


you need to remove the folder ~/Lib/AppSupp/FileWave/FileWaveAdmin


You have some issues with the privileges on that folder or the file "fwxserver-log.txt inside that folder.




It is related to wich FW Admin app you're launching. If you look at the logfile using the FWA (root).app and then try to do the same using the ordinary FWA.app you'll get that error .




HTH


/P-M
P-M Lejon
System Administrator
BonnierNews
Sweden

Hi, I now have a "Could not 06 Sep 2010 13:26 #807

  • jean-philippe.sakael
  • jean-philippe.sakael's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 43
  • Karma: 1
  • Thank you received: 4
Hi,




I now have a "Could not create the FileWave Admin directory" error message


Could it be because my ~ folder is not located on the OS volume ?

Check your privileges 06 Sep 2010 15:49 #808

  • P-M Lejon
  • P-M Lejon's Avatar
  • Offline
  • 5th level - Black Belt
  • 5th level - Black Belt
  • Posts: 92
  • Karma: 3
  • Thank you received: 15

ls -al ~/Library/Application Support/FileWave"/

Should result in something like this:



drwxr-xr-x@ 8 you staff 272 6 Sep 17:44 .
drwx
@ 250 you staff 8500 6 Sep 13:38 ..
-rw-r--r--@ 1 you staff 12292 6 Sep 17:41 .DS_Store
drwxr-xr-x@ 12 you staff 408 21 Aug 19:25 Client Logs
drwxr-xr-x 3 you staff 102 6 Sep 17:44 FileWaveAdmin
-rw-r--r--@ 1 you staff 940604 6 Sep 17:42 FileWaveAdmin.log
drwxr-xr-x@ 9 you staff 306 31 Maj 10:54 FilesetMagicAssistant
drwxr-xr-x@ 19 you staff 646 26 Aug 21:45 QtAdmin

You might have fewer folders, but the important thing is that it's not "root" where should be "you" (where you stands for your shortname).


/P-M
P-M Lejon
System Administrator
BonnierNews
Sweden

~/Library/Application 06 Sep 2010 16:23 #810

  • jean-philippe.sakael
  • jean-philippe.sakael's Avatar Topic Author
  • Offline
  • 2nd Level - Yellow Belt
  • 2nd Level - Yellow Belt
  • Posts: 43
  • Karma: 1
  • Thank you received: 4
~/Library/Application Support/FileWave had root as owner, it is now fixed.




Thanks !
  • Page:
  • 1