FileWave Alliance

The Official Community Forum
  • Page:
  • 1


Custom PKG OS X 22 Aug 2017 16:57 #2669

  • Jamisen Both
  • Jamisen Both's Avatar Topic Author
  • Offline
  • 1st level - White Belt
  • 1st level - White Belt
  • Posts: 3
  • Thank you received: 0
I have about 600 OS X devices currently in Filewave. I have about 60 new OS X devices I need to enroll and get into Filewave. I have updated my server to 12.2 and my custom PKG is still at 11.2.2. It warns me not to use a new PKG with old devices or it can break the connection. I am wondering if I need to update that custom PKG and my old devices will be fine since they have already been sent the upgrade fileset after I updated my server.

Custom PKG OS X 24 Aug 2017 16:33 #2678

  • Bao Tran
  • Bao Tran's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 94
  • Karma: 3
  • Thank you received: 11
The warning is to explicitly not use the custom PKG for upgrading existing clients. There are specific upgrade filesets for both Mac and Windows published in the download page for each release of FileWave.

So custom PKG should be used for
1. Installing FW client on new computer.
2. Including client on disk image, e.g. with FileWave Lightning, or other disk imaging solution.
3. Pushing out FW client to new computers via ARD.
4. Deploying the FW client on Macs via DEP.

FileWave Upgrade Fileset should be used strictly for upgrading existing older FileWave clients to latest version of FileWave client. Do NOT create your own FileWave Upgrade Fileset using the custom PKG. That's when the communication may break.

In light of that I think it's fine to create a new 12.2.0 custom PKG. It saves the system of having to update your 11.2.2 clients on new computers added to FileWave.

Hopefully that clears things up for you and didn't cause any more confusion.
Last Edit: by Bao Tran.
  • Page:
  • 1