FileWave Alliance

The Official Community Forum
  • Page:
  • 1

TOPIC: Client not registering in Filewave after install

Client not registering in Filewave after install 16 Mar 2017 09:54 #2486

  • Camilo de Olivereira
  • Camilo de Olivereira's Avatar Topic Author
  • Offline
  • 1st level - White Belt
  • 1st level - White Belt
  • Posts: 1
  • Thank you received: 0
Client: Macbook Pro Retina mid 2014, macOS Sierra 10.12.3
Filewave version: 11.1.2

Hey guys,

I'm having some issues with installing filewave version 11.1.2 on a macbook. We have around 150 macs and about 10 windows computers and i never was unable to install filewave except on this machine. When i run the installer everything seems to go smoothly, i add the correct server where filewave is installed, the correct port, and "use computer name for client name" is selected and saved. After a reboot of the client i check FileWave Admin> New Client> Desktop Client, and the machine just doesn't show up. I also checked if the client was already added. When i run the Client Monitor on the affected machine itself, i can browse through all the computers listed, but the localhost (127.0.0.1 over port 20010) shows me nothing. I tried renaming the macbook, reinstalling the client, updating the OS to no avail. The macbook doesn't have any any firewall activated or installed or any other security programs running.

Any ideas besides reinstalling OSX?

with kind regards,

Camilo de Oliveira Relvas

Client not registering in Filewave after install 17 Mar 2017 00:11 #2487

  • Bao Tran
  • Bao Tran's Avatar
  • Offline
  • FileWave Staff
  • FileWave Staff
  • Posts: 103
  • Karma: 4
  • Thank you received: 13
Just curious but what do you get if you check to see if the FW client process is running like this?

Sierra:~ billy$ ps -ax | grep fwcld
48 ?? 1:17.40 /usr/local/sbin/FileWave.app/Contents/MacOS/fwcld
602 ttys000 0:00.00 grep fwcld

If the process is present I'd check if it's listening on the client monitor port as listed here - www.filewave.com/support/kb/article/tcp . You should get something like this.

Sierra:~ billy$ sudo lsof -i:20010
Password:
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
fwcld 48 root 26u IPv6 0x96a8c03ec563a3c7 0t0 TCP *:20010 (LISTEN)

If that checks out then you'd probably want to check connectivity with the FW server next. From the client device you'd want to telnet into your FW server address on 20015 to see if you get a response. You should get something like this. If it says "Connection refused. Unable to connect to remote host" then there's something blocking traffic between your client device and the FW server. Replace 10.10.10.210 with the address of your FW server.

Sierra:~ billy$ telnet 10.10.10.210 20015
Trying 10.10.10.210...
Connected to 10.10.10.210.
Escape character is '^]'.
Connection closed by foreign host.

When you reinstalled did you remove the old FW client first? You can get an uninstall script for the FW client from the fileset listed on this page - www.filewave.com/filewave/uninstall-file...ient-through-fileset . Might want to give that a try first if you haven't done so already. Beats having to reinstall macOS for this computer.

Someone mentioned elsewhere on the forums that they had problems with the client showing up because they had a placeholder computer entry present. You might want to check if there's already a computer entry present with the same serial number as this Mac. If so removing it might resolve this issue for you.
Last Edit: by Bao Tran.
  • Page:
  • 1